loader image

Enable PipeWire on Ubuntu 22.04 [Debian Based Systems]

What makes us different from other similar websites? Forums Tech Enable PipeWire on Ubuntu 22.04 [Debian Based Systems]

Viewing 1 post (of 1 total)
  • Author
    Posts
  • #7173
    thumbtak
    Keymaster

    Some devices like Shure USB microphones do not work without this. You have to switch your default sound server to this, for the microphone to work out of the box.

    Enable PipeWire on Ubuntu 22.04

    This guide is only for original Ubuntu out-of-the-box packages. If you have added a custom PPA like pipewire-debian, you might get into conflicts.

    Ubuntu 22.04 has PipeWire partially installed and enabled as it’s used by browsers (WebRTC) for recoding the screeen under Wayland. We can enable remaining parts and use PipeWire for audio and Bluetooth instead of PulseAudio.

    Starting from WirePlumber version 0.4.8 automatic Bluetooth profile switching (e.g. switching from A2DP to HSP/HFP when an application needs microphone access) is supported. Jammy (22.04) repos provide exactly version 0.4.8. So, we’re good.

    Based on Debian Wiki, but simplified for Ubuntu 22.04.

    Install

    Install WirePlumber as the session manager:

    $ sudo apt install pipewire-media-session- wireplumber

    Notice ‘-‘ at the end of ‘pipewire-media-session’. This is to remove it in the same command, because ‘wireplumber’ will be used instead.

    Start WirePlumber for your user:

    $ systemctl --user --now enable wireplumber.service

    Configure

    ALSA

    Install the ALSA plug-in:

    $ sudo apt install pipewire-audio-client-libraries

    And copy the config file from PipeWire docs (provided by the plug-in) into the ALSA configuration directory:

    $ sudo cp /usr/share/doc/pipewire/examples/alsa.conf.d/99-pipewire-default.conf /etc/alsa/conf.d/

    Check if you have other (like Pulse) configs in the /etc/alsa/conf.d/ installed by something else. You might want to remove them.

    PulseAudio

    Everything was done automatically by pipewire-pulse package, which should have been installed by wireplumber package as recommended. If not, install it yourself.

    Bluetooth

    Install the codecs and remove Bluetooth from PulseAudio, so it would be handled directly by PipeWire:

    $ sudo apt install libldacbt-{abr,enc}2 libspa-0.2-bluetooth pulseaudio-module-bluetooth-

    The supported codecs are SBC and LDAC.

    Unfortunately, aptX and AAC are not supported because of patents and other technical reasons. aptX is available starting from 22.10 via libfreeaptx0 installed by default there (22.10 uses PipeWire by default as well). If you really need these codecs in 22.04 you may use this PPA from @aglasgall which is based on universe, but rebuilds pipewire with additional packages for aptX and AAC from multiverse. Read the discussion here.

    Done

    Reboot and check if it works by running:

    $ shutdown -r now
    $ LANG=C pactl info | grep '^Server Name'

    Quoted from:
    https://gist.github.com/the-spyke/2de98b22ff4f978ebf0650c90e82027e

Viewing 1 post (of 1 total)
  • You must be logged in to reply to this topic.
TAKs Shack