TAKs Shack Chat 
Only logged in users are allowed to enter the chat
Mic not working through audio jack [Linux / Fixed] – TAKs Shack
loader image

Mic not working through audio jack [Linux / Fixed]

What makes us different from other similar websites? Forums Tech Mic not working through audio jack [Linux / Fixed]

Viewing 1 post (of 1 total)
  • Author
    Posts
  • #6753
    thumbtak
    Keymaster

    Open terminal and run …
    $ aplay -l

    You will hopefully see an ALC number. An example is something like this.

    card 2: Generic [HD-Audio Generic], device 0: ALC221 Analog [ALC221 Analog]
    Subdevices: 0/1
    Subdevice #0: subdevice #0

    In the example above, you have ALC221. If your output has 22X, 23X, 25X, 269, 27X, 28X, 29X or 3XXX (the X’s are placeholders for any digit such as 221, 222, 223, 224, etc) then give this a try to see if it adds the Headset Mic option to your input devices:

    $ sudo tee /etc/modprobe.d/snd-hda-intel-headset.conf <<<'options snd-hda-intel model=dell-headset-multi'

    Don’t worry about Dell being in the name, regardless of your computer manufacturer. This is the name the ALSA developers gave to the quirk, as it was first discovered with Dell’s.

    Reboot when done, then look to see if you have the new input device.

    You may reboot with the following command …
    $ sudo shutdown -r now

    If that didn’t work, edit the file with
    xed admin:///etc/modprobe.d/snd-hda-intel-headset.conf
    and change the line to this:
    options snd-hda-intel model=headset-mode

    Save the file, ignore the warnings from the terminal, then check the input devices.

    And one more option if that also failed:
    options snd-hda-intel model=headset-mic

    Save. Reboot. Check.

    Good luck.

    P.S. It is common for new devices to be muted at first. If the option showed up but isn’t working check for that.

    You may need to run …
    $ alsamixer
    to unmute.

Viewing 1 post (of 1 total)
  • You must be logged in to reply to this topic.